Thursday, May 7, 2009

Housing Item of the Day--Gobbler Piñata

Hello readers!

I trust everyone has had a good time buying their new houses in the sky?

good good.

I bought one too! I opted for the Krokotopia island on this first go around. I think I bought it because it seems to be one of the least favorite models. haha. You know me . . . that's just how I swing.

So, what was to be the first item in my new house? I said, "yo, y'all want this party started right? RIGHT! You all want this party started quickly? QUICKLY!" And then I threw down some crowns and picked up a Gobbler Piñata.



I hadn't been able to showcase any crown furniture items yet, but now that we're live, it's on! This little number is all set to go into my now developing party room! WOOT!



Bring your bats (not lightning bats though grrr) and come ready for a belly full of candy!!

Happy Dueling!

6 comments:

Cheats and Crackers said...

Is that a friendly dragon you have in that picture? GIVE ME!

Shy said...

Ah! Thomas don't forget to invite me :) I wanna come. Heheh

(The reason you haven't seen me is cause I'm on my life mage! Need to add ya. Send me a message on central on where to meet ya when your gonna come on. Hope to see you soon!)

Cheats and Crackers said...

Man, despite that post you did over at wiz101 central, I still can't make a user that can post and stuff. I create a new account, I click on the thing where it says, "But to activate your account, you must visit this link." Well, I go to that link. It says, "Your account has been activated , but it is in moderation to be added to the forum." It's been about a week now, and it still won't let me do anything. Not even search the posts, like it lets my first account do. You have any idea on what is happening? :(

Matthew Willowblossom said...

Hey Cheats and Crackers,

I've been having the same exact problem with Wizard101 Central. It is really annoying; I can't view any of the pictures or post at all! This is even more annoying for me because it has been going on for four months! I just can't get an account to work and be able to post! Just like you I tried a second account and that one can't even view the threads! I really just want this to get figured out! :(

stingite said...

C&C: there will probably be one up for grabs in the raffle, good luck!

As for the Wiz 101 central, hmm, Have you tried looking at your cookies and internet settings?

Shy: will do!

Cheats and Crackers said...

@Matthew. I'm glad I'm not the only one having this problem. Hopefully friendly's tips will work.

@Friendly No, I don't think that I have tried that. Hopefully it will work. Thanks! And btw, a friendly dragon could be given away? Man, I'm definitely glad I entered. :P